Within any module, the organization of and access to data follow certain principles that are used throughout CC-Assist .NET. An understanding of these basic elements and basic principles of operation that are available in most modules provides an important fundamental understanding of how to work in CC-Assist .NET as a whole.

The basic elements in any module in CC-Assist are as follows:

Video Tutorials

Some basic principles of operation are as follows:

“Module Explorer”

The “Module Explorer” provides a way to navigate through modules and is an alternative to the module menus. The “Module Explorer” is to the left of the module pane and includes the Members, Staff, Groups, Events, Contacts, Inquiries, Accounts Receivable and General Ledger folders. Within each folder are modules, as well subfolders which contain related Value Tables and Library modules where appropriate.

Module pane

The module pane is to the right of the “Module Explorer.” It includes the navigation bar, “List View,” “Detail Views,” “module levels” and the associated menu bars and toolbars.

Navigation bar

The navigation bar is located at the top of the pane. It indicates what module or module level you are in currently. If you have drilled down into another level, clicking on the desired level in the navigation bar returns you to the specified location or module level.

“List View”

The “List View” is displayed directly under the navigation bar. It is a scrollable table comprised of rows which display information about records in the module. Collectively, the rows in the scrollable table comprise a directory of the “parent” records in that module or module level.

The “List View” can be configured to show only the desired columns. In addition, each column displayed in the “List View” can be sorted in ascending or descending order. For more information see Configuring and Navigating within a “List View.”

Menu bars, menus and toolbars related to the “List View” will change to reflect the functionality related to the module level in which you are working. You can access some of the “List View” menu items by performing a right click in the “List View” table. This displays a popup menu containing items on the respectively-named menu. For more information about the menu associated with “List Views,” see “List View” menu.

“Detail View”

Selecting a record from the “List View” displays information for the record in the “Detail View” below. Data in the “Detail View” is stored in text boxes, drop down boxes and look up text boxes. Data is entered by either typing in the information, choosing an item from a selection dialog box and/or retrieving data from a related Library.

Scrollable tables can also be located within a record or “Detail View.” In this case, the table contains “child” records.

For example, below you see the Members module pane. Near the top of the pane and below the Members toolbar is the Members “List View.” The Member record selected in the “List View” is the ~A/R Transaction Orphanage. Below the “List View” in the Members “Detail View”: “Account page is a scrollable table listing this A/R transactions, or “child” records, associated with the ~A/R Transaction Orphanage.

Any of these transactions can be opened in which additional information about the transaction may be viewed.

In instances such as this, the “Detail View” will have table menu that includes an “Open Row” option which will allow a user to drill-down into another module level as shown below. The related table menu in this example is called the Account menu.

Module level

A module is a hierarchal presentation of a specific type of records and their related “child” records. A module is organized into module levels. A module level displays the records at a specific level within the module. For example, in the Members module, the first level displays all of the Member records in the “List View” and the detailed information for the currently selected member in the “Detail View.” If you go to the “Account” page (as shown in the example above) in the “Detail View,” you can drill-down to another level, the Account level. In this level the transactions for the member will be displayed in the Account “List View” and detailed information for each transaction can be viewed in the “Detail View.”

Menu bars, toolbars and menus

Menu bars & toolbars

Menu bars

Menu bars, which are located directly below the application title bar, display titles of available menus. Most modules have the following menus: Module menu, View menu, Table menu(s) (menu associated with the active module level(s) “List View”), Output menu, Window menu and Help menu.

When a menu title is chosen from the menu bar, a drop-down menu is displayed on which menu items (choices) are listed. Depending on the menu, the items offer choices for use in…

  • navigating to other modules and other functionality (Module menu and Window menu)
  • creating output (Output menu)
  • accessing the CC-Assist Help System (Help menu)
  • Opening a record, adding a record, deleting a record or accessing available procedures (Table menu-e.g. Members menu, Reps menu, Account menu, etc.)

Toolbars, which are located directly below each navigation bar in the “List View” and “Detail View,” display controls and/or commands that correspond to items on some menus. Thus, using the toolbar is simply a shortcut for choosing an item from one of these menus.

When the mouse is passed over any item on the toolbar, CC-Assist displays a tool tip that explains the item’s purpose.

Menus

Most modules have the following menus: Module menu, View menu, Table menu(s) (menu(s) associated with the active module level(s) “List View”), Output menu, Window menu and Help menu.

Module menu

The Module menu lists types of modules in CC-Assist. When a menu item is chosen, a submenu is displayed on which modules that are of that type are listed. The Module menu is used for navigating from module to module. (For more information, see “Modular Structure of CC-Assist.“)

View menu

The View menu has options for different functionality in the program. Choosing “Module Explorer” displays the “Module Explorer” pane. The “Reminders” item displays a window of the reminders that have been set up in the Contacts module for the currently logged in user. “Sessions” displays a window indicating which users are currently logged into the program.

“List View”, or Table menu

The “List View” menu contains options for adding and deleting records, as well as other procedures available within a module or module level. The name of the menu corresponds to the related module level. Therefore, when in the Members module, the corresponding “List View” menu will be referred to as the Members menu. “New Row”, “Delete Row”, “Open Row”, “Add/Remove”, “Show All” and “Procedures” are often listed under a Module menu.

Note: If you are able to drill down into a record within a table in the “Detail View” of a module pane, you will see another table menu related to the other available module level. This menu will be displayed to the right of an Output menu.

    • Choosing “New Row” creates a new blank record where you may add the new record’s information. In some cases selecting this option drills down into another module level.

The corresponding toolbar control for this menu item is:

    • Choosing “Delete Row” deletes the currently selected or “highlighted” record. Choose this item if you want to delete an existing record, and/or if you inadvertently chose the “New Row” item and unintentionally created a new blank record. (Note: A deleted record cannot be “undeleted.” Therefore, be certain that you want to delete it before doing so.)

The corresponding toolbar control for this menu item is:

The corresponding toolbar control for this menu item is:

    • Choosing “Add/Remove…” opens a selection dialog box. There are command buttons below the scrollable table. Examples of these commands are “Choose” and “Cancel” or “OK” and “Cancel.” Choosing any of these command buttons dismisses the selection dialog box and returns the focus back to the point at which you invoked it. If you made a selection(s) from the selection dialog box, the text box will automatically be filled in with your selection(s). If you did not make a selection(s) from the selection dialog box, the text box will remain as it was before you invoked the “lookup” command. An example of this is in the Rep “Detail View”: “Groups” page. When this command is chosen, a multiple-selection dialog box is displayed in which there is a scrollable table of groups from which you can choose one or more to assign to the rep.

The corresponding toolbar control for this menu item is:

    • “Show All”: Choosing this menu item displays all records for the current table according to the Quick View Options that are set for the database. To edit these options, close all other modules and select the Tools menu and choose Options. The “Options” window will allow a user to configure which Contacts, Transactions and Events are to be viewed when the “Show All” feature is not chosen.

The corresponding toolbar control for this menu item is:

    • “Procedures”: Choosing this menu item displays a selection dialog box from which you can choose standard procedures or any other procedures that are implemented as “installed options.” Procedures allow you to update or create multiple records quickly.

Examples of some standard procedures available within the Members module are:

Examples of standard procedures available within the Accounts Receivable module are:

Output menu

The Output menu lists types of output items that you can choose for printing and/or exporting data from CC-Assist (e.g. reports, listings, labels, nametags, invoices, etc.) The output items displayed are based on the “List View” of the currently selected module level. For more information, see “Creating output.”)

Window menu

The Window menu lists all modules that are currently open in CC-Assist.

Choosing the name of another open module from this menu activates that module without closing the module in which you are currently working. (For more information, see “Open vs. Active.”)

Help menu

The Help menu provides access to the CC-Assist Help System, which has three sections: The User’s Guide, the Reference Manual, and the Training Agenda.

  • The User’s Guide provides “how to” instructions on performing various procedures. Therefore, it should be used when you need only a listing of steps to follow for doing a particular procedure. It is not intended to provide an overall understanding of CC-Assist.
  • The Reference Manual provides a thorough explanation of the program as a whole.
  • The Training Agenda provides a list of training phases, including reading assignments, hands-on assignments, and intended purpose of each training phase.

Scrollable tables, records, text boxes, and selection dialog boxes

Scrollable tables

A scrollable table is a table within a “List View” and occasionally a “Detail View.” These tables are used for opening, deleting and/or adding new records. Records are displayed, deleted, and/or added via these scrollable tables.

Records

Within each module is a “List View” which contains a listing of all records in that module. There is a “Detail View” for each record. Some “Detail Views” contain multiple tabbed pages of information relating to that record. For example, in the Members module, there is a “List View” which includes records of all companies. Each company is a record. Information related to a record is displayed below the “List View” in a “Detail View.”

Text boxes and selection dialog boxes

Most of the data items in a “Detail View” are stored in text boxes. Text boxes vary not only in size, but also in the way in which data can be entered. The area in a text box may only be one line, and may be restricted in length, such as a text box in which you type a date. Below are the types of text boxes you will see in CC-Assist .NET.

  • Standard text box – A standard text box is a text box in which you can enter data only by typing it.
  • Lookup text box – A lookup text box is a text box in which you can type data or, optionally, choose a “lookup” command to display a selection dialog box from which you can “look up” and choose data to automatically fill in the look-up text box. An example of a look-up text box is in the Member “Detail View”: “Classes” page in which there are five lookup text boxes in which you can enter a business category code.
  • Drop-down combo box A drop-down combo box combines the characteristics of a text box with a drop-down list box. It has a “drop-down” command button to its right, which is denoted by a down arrow. When the “drop-down” command is chosen, a list of items from the associated Value Table module is displayed. You can choose one item to enter in the text box drop down. The Members “Detail View”: “Basic Info 1” page “Status” text box is an example of a drop down text box.
  • Retrieval of data from a Library Data may also be entered in some text boxes by retrieving it from a Library. For example, a message that you want to print on an A/R invoice may be retrieved from the A/R Invoice Messages module.

Configuring and navigating within a scrollable table.

Most scrollable tables in CC-Assist are completely configurable. For example, you can select which columns will show in a “List View,” you can sort the chosen columns in ascending and descending order (see “Selecting Columns and Sorting”) and you can easily find a desired record within a table by using the incremental search.

Selecting columns and sorting records

Most tables are fully configurable, which means a user can select or deselect columns to display. To do this, right click in the table and choose “Select Columns.” Add and/or remove columns from this window. Each column chosen can then be sorted in ascending or descending order by clicking on the column header. A sort icon (glyph) will appear in the column header indicating the direction of the sort.

Selecting a column and finding a record in a scrollable table (incremental search)

The incremental search facility can be used to quickly find any record in a table.

  • Using the incremental search to find a name or description – Select the desired column header and type one or more of the beginning letters in the name or description that you want to find. The focus in the table will move to the row that most closely matches what you typed. If you type something that cannot be found, the feedback at the top of the selected column turns red, and no more letters will be accepted. Press “Esc” to end the search and start a new search.
  • Using the incremental search to find a number – Select the desired column header and type one or more numbers in the same format as the numbers in the selected column. The focus in the table will move to the row that most closely matches what you entered. If the number you typed is not found, the feedback will turn red, and the focus will move to the row with the first number larger that want you typed.
    For example, if you wish to find a member whose Mem # is 1012, first select the Mem # column header. Then type “1012.” Observe what happens to the focus as you type each digit.
  • Using the incremental search to find a date – Select the “date” column header and type the date that you want to find. (You must type a full date: mm/dd/yyyy.) The focus in the table will move to the row that most closely matches what you typed. If the date you typed is not found, the feedback will turn red.